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Decision-making Functions

Excel’s functions are formulas that you create in the worksheet. A function’s
arguments can be constant values or formulas. When a function’s argument is
another function, it is called a nested function. You can nest up to seven levels of
functions in a formula.

If Functions =If(logical_test,value_if_true,value_if_false)

The If function enables you to perform a calculation only if a certain condition is
TRUE, and to perform a different calculation if that condition is FALSE. The
value_if_true and value_if_false results can be either values or text. If the result
is text, it must be enclosed in quotes.

If functions are divided into three sections:

1. Logical_test is any value or expression resulting in TRUE or FALSE.

2. Value_if_true is the value (or formula resulting in a value) that will be entered
into the worksheet if the logical_test is TRUE.

3. Value_if_false is the value (or formula resulting in a value) that will be entered
into the worksheet if the logical_test is FALSE.

Example:

=if(A4>5,A4/2,0)

If A4 = 8, then logical_test (A4>5) is TRUE, and the function returns the
value_if_true (A4/2).

If A4 = 2, then logical_test (A4>5) is FALSE, and the function returns the
value_if_false (0).

Example:

=if(A4>5,”Yes”,”No”)

If A4 = 8, then logical_test (A4>5) is TRUE, and the function returns Yes.

If A4 = 2, then logical_test (A4>5) is FALSE, and the function returns No.

Task: Create Formulas Using The If Function

The object of this task is to create If functions in a worksheet that will determine
if certain arguments are true or false.

What you do: Comments/Prompts

1. Open Sales Contest.xlsx.



Page 2

2. Delete the data in G8:G12.

3. Click in cell G8 and click on the
Paste Function icon on the
Standard Toolbar.

4. Click on the Logical Function
Category.

A list of function names will display on
the right side of the Dialog Box.

5. Click on IF.

6. Click OK.

To open the IF Dialog Box.

7. In the Logical-test box, type:
f8>quota.

8. Press: [Tab].

This will check to see if Cell F8 is
greater than the quota.

9. In the Value_if_true box, type:
comm_rate*f8.

10.Press: [Tab].

If the Logical test is true, then
multiply the commission rate times
Cell F8.

11. In the Value_if_false box, type: 0.

12.Click OK.

If the Logical test is false, then type a
0.

13.Copy the formula in Cell G8 down to
Cell G12.

Notice the results of the formulas in
those cells.

14.Select the range G8:G12.

15. In the Formula Bar, replace the 0
with “Below Quota”.

16.Press: [Ctrl] + [Enter]. To copy the edited formula to the
selected cells.

17.Save the file.

Nested If Functions

Used alone, an IF function can choose from only two calculations (TRUE or
FALSE). You can, however, choose to nest IF functions within other IF functions.
You are limited to seven levels within a nested function. (Note: When working
with nested functions, you will have multiple open parentheses. For every
open parenthesis, there must be a close parenthesis.)
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Example:

=if(A4<50,A4/2,if(A4>100,”Yes”,0))

If A4 = 24, then logical_test (A4<50) is TRUE, and the function
returns the value_if_true (A4/2).

If A4 = 150, then the second logical_test (A4>100) is TRUE, and
the function returns the second value_if_true (Yes).

If A4 = 75, then logical_test (A4<50) and (A4>100) is FALSE, and
the function returns the value_if_false (0).

Task: Create Formulas Using A Nested If Function

The object of this task is to create a formula that contains multiple If functions in
a worksheet. Ensure that Sales Contest.xlsx is still open.

What you do: Comments/Prompts

1. Delete the data in the range H8:H12.

2. Click in Cell H8.

3. Click on the Paste Function icon on
the Standard Toolbar.

4. Click on IF from the Most Recently
Used category.

5. Click OK.

To open the IF Dialog Box.

6. In the Logical-test box, type: f8>70.

7. Press: [Tab].

This will check to see if cell position F8
is greater than 70.

8. In the Value_if_true box, type: 10.

9. Press: [Tab].

If the Logical test is true, then place
a 10 in Cell H8. These people will get a
10% bonus.

To move to the Value_if_false box.

10.Place the mouse pointer anywhere
inside the gray area of the IF Dialog
Box and drag it to the middle of the
worksheet.

So you can see the Formula Bar at
the top of the worksheet.
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11.Click on the IF Button to the left of
the Formula Bar.

A blank IF Dialog Box will display on
the screen.

12. In the Logical-test box, type: f8>60.

13.Press: [Tab].

This will check to see if Cell F8 is
greater than 60.

14. In the Value_if_true box, type: 8.

15.Press: [Tab].

If the Logical test is true, then place
an 8 in Cell H8. These people will get
an 8% bonus.

To move to the Value_if_false box.

16.Click on the IF Button to the left of
the Formula Bar.

A blank IF Dialog Box will display on
the screen.

17. In the Logical-test box, type: f8>50.

18.Press: [Tab].

This will check to see if Cell F8 is
greater than 50.

19. In the Value_if_true box, type: 4.

20.Press: [Tab].

If the Logical test is true, then place a
4 in Cell H8. These people will get a 4%
bonus.

To move to the Value_if_false box.

21.Click on the IF Button to the left of
the Formula Bar.

A blank IF Dialog Box will display on
the screen.

22. In the Logical-test box, type: f8>30.

23.Press: [Tab].

This will check to see if Cell F8 is
greater than 30.

24. In the Value_if_true box, type: 2. If the Logical test is true, then place a
2 in Cell H8. These people will get a 2%
bonus.

25. In the Value_if_false box, type: 0. If the Logical test is false, then type a
0.

26.Click OK. The resulting formula should look as
follows:

=IF(F8>70,10,IF(F8>60,8,IF(F8>50,4,IF(F8>30,2,0))))

27.Copy the formula in Cell G8 down to
Cell G12.

Notice the results of the formulas in
those cells.

28.Save and close the file.
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Summarize Multiple Worksheets

You can summarize numbers in multiple worksheets into a Summary Sheet. This
allows you to view the total for all the sheets combined, or look at the totals for
individual sheets. An example of how this would be used is in an annual budget.
You would have an individual sheet for Qtr 1, Qtr 2, Qtr 3, and Qtr 4. You would
then have another sheet that would total the four quarters and be able to view the
entire year’s budget on one sheet.

Task: Summarize Multiple Worksheets

The object of this task is to add the values together from multiple worksheets into a
summary sheet.

What you do: Comments/Prompts

1. Open Sales Workbook.xlsx.

2. Click in Cell C5.

3. Type =sum( To begin the formula that will calculate
the total Quantity sold by all three
salesmen.

4. Click on the Jones tab and click in
Cell C5.

To tell Excel where the first value is to
be summed.

5. Hold down the [Shift] key and click
on the Andrews tab.

To select all three worksheet tabs.

6. Press [Enter] to complete the
formula.

Excel will add all the numbers together
that are in Cell C5 from the three
worksheets.

7. Click in Cell D5.

8. Type =sum(

9. Click on the Jones tab and click in
Cell D5.

10.Hold down the [Shift] key and click
on the Andrews tab.
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11. Press [Enter] to complete the
formula.

Excel will add all the numbers together
that are in Cell D5 from the three
worksheets.

12.Click in Cell E5.

13.Type: =sum(

14.Click on the Jones tab and click in
Cell E5.

15.Hold down the [Shift] key and click
on the Andrews tab.

16.Press [Enter] to complete the
formula.

Excel will add all the numbers together
that are in Cell E5 from the three
worksheets.

17.Select Cells C5:E5.

18.Place the mouse pointer on the
lower-right corner of the selected
area.

The mouse pointer will turn into a thin
black cross.

19.Hold down the Left Mouse Button
and drag down to Row 14.

To copy the formulas to the remaining
rows.

20.Save and close the file.

Calculate Single Cells From Multiple Worksheets

You can also create formulas that will calculate values within multiple worksheets
and/or files without using the SUM function. In this case you would make sure that
you have all of the files open that contain the values to be calculated. You add the
values to the formula by clicking on the appropriate worksheet and cell.
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Task: Calculate Single Cells From Multiple Worksheets

The object of this task is to add values together from multiple worksheets and files
into a single cell.

What you do: Comments/Prompts

1. Click on the Open icon on the
Standard Toolbar.

The Open Dialog Box will display.

2. Click once on Advanced
Formulas.xlsx.

To select the first file to open.

3. Hold down the [Ctrl] key and click
once on Sales.xls.

To select the second file to open.

4. Click on the Open button. To open both files simultaneously. You
should be in the Sales.xls file.

5. Click in Cell B1. To make that the active cell.

6. Type = To begin the formula.

7. Click on Cell G14. This cell will contain the first value in
the formula.

8. Press: +

9. Click on Cell G31. To add that value to the formula.

10.Press: +

11.Click on the Window, Advanced
Formulas.xlsx Menus.

To switch to the Advanced Formulas
workbook.

12.Click on Cell F6. To add that cell to the formula.

13.Press: [Enter]. To complete the formula. Excel will
switch you back to the Sales.xls
workbook and move you down to Cell
B2.

14.Press the [Up Arrow] key on the
keyboard.

To return to Cell B1.
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15.Look at the formula in the Formula
Bar.

=G14+G31+'[Advanced
Formulas.xlsx]Auditing'!$F$6

Notice that Excel adds the name of the
workbook and worksheet to the formula
when you switched to click on Cell F6.
Also notice that Cell F6 is an absolute
cell value.

16.Save and close both files.

Finding, Sorting, and Filtering Data

Long lists of data can be intimidating, but Microsoft Excel has excellent sorting and
filtering capabilities to help bring that data under control. This tutorial shows you
several strategies for finding and organizing data.

Using Excel As A Database Application

For simple lists of data, Excel can function as a perfectly good database application,
and is simple to use. Excel works great for flat file databases. A flat file database
consists of a single sheet of rows and columns. The first row contains the column
headers, and the subsequent rows contain data.

Creating your data table

First, let's review some database terminology, using a familiar example -- an
address book.

When constructing a data table in Excel, it's important to put the field names in the
first row. Field names describe the type of data placed in each column. For an
address book, the field names might include FirstName, LastName, Address, City,
State, and ZIP. In subsequent rows, enter the specific entries for each person. Each
row is for a different person and is called a record.

The first step in creating a data table is to place the field names in row 1. You can
format the field names differently if you like (such as making them bold or a
different color), but that's purely a matter of aesthetics; Excel doesn't assign any
particular meaning to the formatting.
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Follow these steps to create a phone list for a club:

1. Start a new workbook, and on Sheet1, enter the following:

Al: First

A2: Last

A3: City

A4: State

A5: Phone
A6: A4: Membership

2. Select row 1, and then apply bold formatting to it.

3. Select columns A through F, and then set their column widths to 15.

4. Next, enter records shown below into the worksheet.

A B C D E F
First Last City State Phone Membership

Bob Adams Jackson TN 317-555-2818 Active
John Smith Jackson MS 317-555-8191 Active
Wayne Baker Memphis TN 765-555–U17 Active
Kathy Jones Memphis AR 765-555-8271 In active
Pam White Ft. Wayne IN 217-555-3230 Active

5. Save your work as Int-Practice3.xlsx, and then close the file.

Finding and replacing data

So far, most of the worksheets you've worked with in this course have been small, so
it was easy to find data at a glance. When you get 50 or so records in a database,
however, finding a specific record starts becoming more difficult by just browsing.

You can locate data in an Excel database in many ways, but perhaps the simplest
and most user-friendly is the Find command. To use it, press Ctrl+F or, on the
Home tab, click on the Find & Select > Find button on the right side of the
Ribbon. Either way, the Find and Replace dialog box opens, with the Find tab
displayed. Type the text string you want to locate, and then click Find Next to
jump to the next cell in the worksheet that contains that string.

You also can set options for finding. Try the following exercise to see some of them:

1. In Int-Practice3.xlsx you created above, on the Home tab, select Find & Select >

Find.

2. In the Find and Replace dialog box, type Wayne in the Find what text box.
3. Click the Options button to expand the options.
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4. Leave the Within, Search, and Look in boxes set at their defaults for now. Here's

what each of those settings does:

Within: Specifies whether to search the current sheet only or the entire
workbook.

Search: Specifies whether to search by row or by column.

Look in: Specifies whether to search in formulas, values, or comments.
Unless a particular cell contains a formula or function, it makes no
difference whether you select Values or Formulas.

5. Check the Match case check box. This limits the search to the
capitalization you typed in the Find what text box.

6. Click Find Next. Keep doing that until you've cycled through all instances in
the sheet. Notice that it finds one instance of "Fort Wayne" and one instance in
which Wayne is the person's name.

7. After you reach the first instance again, check the Match entire cell contents
check box. Then click Find Next. This time Excel only finds the first name
"Wayne".

8. Click Close to close the Find and Replace dialog box.
9. Leave the file open for later use in this lesson.

You can also use the Find and Replace dialog box to replace data. Click the
Replace tab and specify what you want to replace the found text with.

Sorting worksheet data

As you just learned, one way to locate certain data is to use the Find feature.
Another way is to sort the records by a particular column and then scroll through
the data to find what you want.

To do a simple sort by a single column, use the Sort & Filter button on the
Home tab. Follow these steps to try it out with your sample file:

1. In Int-Practice3.xlsx, click in the First column (any row).

2. On the Home tab, select Sort & Filter > Sort A to Z.
3. Click the Data tab. (More sorting options are available on the Data tab.)
4. In the Sort & Filter group, click the Sort Z to A button.

You can also do more advanced sorts by multiple columns at once. For example, if
duplicate values are in the primary field by which you're sorting, Excel refers to
the secondary sort field. To try out a multiple-field sort, follow these steps:
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1. In Int-Practice3.xlsx, on the Data tab, click the Sort button. The Sort dialog box
opens.

2. Open the Sort by list, and then select State.
3. Click Add Level.
4. Open the Then by list, and then select Membership.

5. Click OK.

Filtering data

As you learned in the preceding section, sorting helps you find specific records that
met particular criteria alphabetically in a certain field. For example, when you sort
by ZIP code, it's easy to scroll through the worksheet and find the people who live in
any given ZIP code.

However, a filter can be an even better way of finding certain records, because a
filter enables you to hide the records that don't meet your criteria.

The easiest way to filter a list is to turn on the Filter feature (on the Data tab), if it
isn't already on, and then use the drop-down list buttons at the top of each column
to set up your filtering.

Give this a try with your sample data. Follow these steps:

1. In Int-Practice3.xlsx, click the Data tab. If the Filter button isn't already
selected, click it.

2. Open the drop-down list at the top of the State column (column D), and then
clear the Select All check box. Check the IN and TN check boxes, and then click
OK. The list is filtered to show only people who live in those two states.

3. Click the Clear button on the Data tab. The filter is removed, and the full set of
data reappears.

4. Open the First column's drop-down list, and then select Text Filters >
Contains. The Custom AutoFilter dialog box opens.

5. In the text box to the right of "contains," type Pam.

6. Click on the Or option and click on the second drop down arrow.

7. Click on Contains.

8. In the text box to the right of "contains," type Bob.

9. Click OK. The list is filtered to show only those records that match the criteria.

10. Click the drop-down list button for the First column again, and select Clear
Filter From "First."

11. Click on the Filter icon on the Ribbon to turn off the filtering capability.

12. Close the file, saving your changes.
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Splitting data into multiple columns

Sometimes when you set up a database, you make a bad decision initially about
what information will be separate and what will be combined. For example, many
people decide to put first and last names together in a single column in an address
book, calling it Name. Later, they realize they want to be able to sort the list by last
name, but there's no way to do it because each entry begins with the person's first
name.

The opposite can also occur. Perhaps you originally decided to separate the first
and last names, but then you decide you want to use them together.

Neither of these problems is insurmountable.

First, look at a situation in which two words exist in a single cell and you want
them separated. To experiment with this, follow these steps:

1. Start a new blank workbook, and then save it as Int-Practice4.xlsx.

2. Enter the data shown in Figure 3-9.

Tom Smith
Bill Thompson
Paul Smith
Emily Jackson
Rose Jones

3. Select the range Al :A5.
4. On the Data tab, click Text to Columns.
5. Select Delimited, and then click Next.
6. Clear the Tab check box, and then check the Space check box.
7. Click Finish. The names are broken into two separate columns.
8. Save your work. Leave the file open for later use in this lesson.

Notice that the steps split the data into the column to the right of the current one.
You must have a blank column to the right of the column containing the
original data when you use this command.

Next, you'll look at the opposite situation: concatenating data.



Page 13

Concatenating data

Now let's look at the opposite situation. Suppose that you've already split data into
two or more columns and now you decide you want it combined. (That's what
concatenate means -- to combine.)

You can combine data in two ways: a temporary way and a permanent way. Use the
temporary way when you want to use the data in a single cell elsewhere in the
worksheet but retain the separate values. Use the permanent way when you don't
need to go back.

Concatenating data temporarily

To merge data temporarily, create a new column, and in it, set up formulas that
concatenate the values of the individual cells.

Let's do this with the example file:

In Int-Practice4.xlsx, in cell C1, enter the formula =A1&" "&B1.

The & sign is the concatenation operator, so technically =A1&B1 would put the
two values together. However, there would be no space between them. That's why
the " " exist. It's a space, nestled between two quotation marks.

1. Copy the formula from cell C1 to the range C2:C6.
2. Widen column C as needed.

Note: You can also use the CONCATENATE function to do the same thing,
like this: =CONCATENATE(Al," ",B2)

Notice that with the function, you separate the pieces with commas rather than &
signs because each piece is a separate argument.

Concatenating data permanently

The formulas or functions you set up in the preceding section maintain their
reference to the original cells, so the new values don't really replace the old ones.
You couldn't delete the original first and last name columns, for example, because
then the formulas or functions would have errors.

If you want to permanently replace the two-column names with the one-column
names, create the formulas or functions, as in the preceding section, and then use
Paste Special to paste only the values.

Follow these steps to try it out on your sample data:

1. In Int-Practice4.xlsx, in cell C1, select C1:C6, and then press Ctrl+C to copy the
range to the Clipboard.
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2. Click cell D1.
3. On the Home tab, click the down arrow under the Paste button and click Paste

Values.
4. Select column D, and then press Ctrl+X to cut it.

5. Select column C, and then press Ctrl+V to paste the values into
that column.

6. Save your work and close the file.

Using Subtotals

Automatic subtotals are useful in summarizing the data contained in a list.
Subtotals are created by using Sum, Count, or Average functions. To use subtotals,
the data must be organized in a properly designed list.

Turn On Subtotals

1. Open Sort Data.xlsx.

2. Click on the Payroll worksheet tab.

3. Click in the LOCATION column and click on the Sort Ascending icon on the
Standard Toolbar.

4. Click on the Data Menu and then click on the
Subtotal icon on the right side of the Ribbon.

5. Click on the Down Arrow at the At Each
Change in field.

6. Click on LOCATION.

7. Click in the HOURLY RATE and GROSS
PAY boxes to add a checkmark.

8. Click OK.

 Notice that the list is subtotaled at the end
of each location.

 Notice that there is a grand total at the
bottom of the entire list.

 Notice that there are three boxes to the left of Column A and the row
numbers. These three boxes indicate the different Outline Views that are
available in a Subtotal environment. You are currently in the third outline
view, which displays all of the records in the list
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9. Click on the first button. This will hide all
of the rows and
only display the
Grand Total.

10.Click on the second button. This will hide the
detail rows and
only display
Subtotals and the
Grand Total.

11. Click on the Plus Sign (+) to the
left of Blue Ridge Total.

The hidden rows will display and
turn the plus sign (+) into a minus
sign (-).

12.Click on the Minus Sign (-) to the
left of Blue Ridge Total.

The rows will hide again and only
display subtotals.

13.Click on the third button. This will unhide
all of the rows and
display all
Subtotals and the
Grand Total.
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14.Click on the Data menu, then
click on the Subtotal icon.

To display the Subtotals Dialog
Box.

15.Click on Page break between
groups to add a checkmark.

16.Click OK. Excel will add a page
break after each subtotal.

17.Click on the Print Preview icon
and view the different pages.

18.Close out of Print Preview.

Remove Subtotals

1. Click anywhere inside the list.

2. Click on the Data Menu, then click on the Subtotal icon on the right side of the
Ribbon.

3. Click on the Remove All button.

Work With Ranges Of Data

A Range is any rectangular area within the worksheet. It can be one cell, multiple
cells, a column, or a row. A Range Name is a description that you assign to a cell
or a group of cells. Names are an alternative to cell references. Once a name has
been defined, you can refer to it in a formula; for example, =SUM(Year1). You can
use range names to move quickly to a certain area of the worksheet or to specify
print ranges.

Range Name Guidelines:

 The first character must be text or an underscore character. Other characters
can be text, number, periods, and the underscore.

 Range names can be up to 255 characters long.

 A range name CANNOT contain spaces.
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 Range names are not case sensitive. You can use either upper-case and/or lower-
case characters.

Create Range Names

1. Select the cell or range of cells that you want to name.

2. Click in the Name Box in the upper-left corner of the Excel window.

3. Type the range name using the guidelines displayed above.

4. Press [Enter].

Task: Create Range Names

The object of this task is to create range names in the Long Report.xls workbook.

What you do: Comments/Prompts

1. Open Long Report.xls.

2. Select cell positions B8:B16.

3. Click in the Name Box in the
upper-left corner of the window.

It is to the left of the Formula Bar.

4. Type: January.

5. Press: [Enter].

6. Select cell positions C8:C16.

7. Click in the Name Box in the
upper-left corner of the window.

8. Type: February.

9. Press: [Enter].

10.Select cell positions A7:J16. This will select all of the data.

11.Click in the Name Box in the
upper-left corner of the window.

12.Type: Data. To name the entire selected range
“data”.

13.Press: [Enter]. Make sure that the data is still
selected.

14.Click on the Formulas menu, and
click on the Create from
Selection icon on the Ribbon.

The Create Names Dialog Box will
display.
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15.Make sure there is a checkmark
in Top Row only.

16.Click OK.

17.Click in the Name Box and click
on March.

This will create range names for each
column in the selected area.

The data under the March heading
will be highlighted.

Go To A Range Name

You can go to a Range Name by selecting it from the Name Box. Once you have a
Range Name selected, you can print it, delete it, or add/edit data.

1. Click on the Down Arrow to the right of the Name Box.

2. All of the worksheet’s Range Names will be displayed.

3. Click on the range name to go to that range.

Use Range Names In Formulas

Instead of trying to recall the correct cell address to enter in a formula, you can
enter a Range Name. This is quicker and more accurate. Click in the cell in which
the formula will be entered. Type =sum(RangeName) and press [Enter]. Excel
will sum the column/row and move you to the next row. (For example,
=sum(January) will total an entire column of January figures.)

1. Click in cell position B18.

2. Type: =sum(January).

3. Press: [Enter].

4. Click in cell position C18.

5. Type: =sum(February).

6. Press: [Enter].
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Edit And Delete Range Names

If you make an error when creating a Range Name, you can edit it without having
to recreate the range. You can also use this dialog box to delete existing range
names.

1. Click on the Formulas menu, and
click on the Name Manager icon on
the Ribbon.

2. Click on the Range Name to edit.

3. Change the cell range in the Refers
to: box at the bottom of the dialog
box.

4. Click on Close.

5. Click on the Formulas menu, and
click on the Name Manager icon on
the Ribbon.

6. Click on the Range Name to delete.

7. Click on the Delete button.

8. Click on Close.


